summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py
diff options
context:
space:
mode:
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py
new file mode 100644
index 0000000..f11b90d
--- /dev/null
+++ b/venv/lib/python3.11/site-packages/litestar/openapi/spec/external_documentation.py
@@ -0,0 +1,21 @@
+from __future__ import annotations
+
+from dataclasses import dataclass
+
+from litestar.openapi.spec.base import BaseSchemaObject
+
+__all__ = ("ExternalDocumentation",)
+
+
+@dataclass
+class ExternalDocumentation(BaseSchemaObject):
+ """Allows referencing an external resource for extended documentation."""
+
+ url: str
+ """**REQUIRED**. The URL for the target documentation. Value MUST be in the form of a URL."""
+
+ description: str | None = None
+ """A short description of the target documentation.
+
+ `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation.
+ """