summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
diff options
context:
space:
mode:
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py21
1 files changed, 0 insertions, 21 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
deleted file mode 100644
index b816288..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
+++ /dev/null
@@ -1,21 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-__all__ = ("Contact",)
-
-
-@dataclass
-class Contact(BaseSchemaObject):
- """Contact information for the exposed API."""
-
- name: str | None = None
- """The identifying name of the contact person/organization."""
-
- url: str | None = None
- """The URL pointing to the contact information. MUST be in the form of a URL."""
-
- email: str | None = None
- """The email address of the contact person/organization. MUST be in the form of an email address."""