summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py
diff options
context:
space:
mode:
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py29
1 files changed, 0 insertions, 29 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py b/venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py
deleted file mode 100644
index 5796a48..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/datastructures.py
+++ /dev/null
@@ -1,29 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass, field
-from typing import TYPE_CHECKING
-
-from litestar.enums import MediaType
-
-if TYPE_CHECKING:
- from litestar.openapi.spec import Example
- from litestar.types import DataContainerType
-
-
-__all__ = ("ResponseSpec",)
-
-
-@dataclass
-class ResponseSpec:
- """Container type of additional responses."""
-
- data_container: DataContainerType | None
- """A model that describes the content of the response."""
- generate_examples: bool = field(default=True)
- """Generate examples for the response content."""
- description: str = field(default="Additional response")
- """A description of the response."""
- media_type: MediaType = field(default=MediaType.JSON)
- """Response media type."""
- examples: list[Example] | None = field(default=None)
- """A list of Example models."""