summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
commit6d7ba58f880be618ade07f8ea080fe8c4bf8a896 (patch)
treeb1c931051ffcebd2bd9d61d98d6233ffa289bbce /venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py
parent4f884c9abc32990b4061a1bb6997b4b37e58ea0b (diff)
venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py
new file mode 100644
index 0000000..c59c542
--- /dev/null
+++ b/venv/lib/python3.11/site-packages/litestar/openapi/spec/server_variable.py
@@ -0,0 +1,32 @@
+from __future__ import annotations
+
+from dataclasses import dataclass
+
+from litestar.openapi.spec.base import BaseSchemaObject
+
+__all__ = ("ServerVariable",)
+
+
+@dataclass
+class ServerVariable(BaseSchemaObject):
+ """An object representing a Server Variable for server URL template substitution."""
+
+ default: str
+ """**REQUIRED**. The default value to use for substitution, which SHALL be sent if an alternate value is _not_
+ supplied. Note this behavior is different than the
+ `Schema Object's <https://spec.openapis.org/oas/v3.1.0#schemaObject>`_ treatment of default values, because in those
+ cases parameter values are optional. If the `enum <https://spec.openapis.org/oas/v3.1.0#serverVariableEnum>`_ is
+ defined, the value MUST exist in the enum's values.
+ """
+
+ enum: list[str] | None = None
+ """An enumeration of string values to be used if the substitution options are from a limited set.
+
+ The array SHOULD NOT be empty.
+ """
+
+ description: str | None = None
+ """An optional description for the server variable.
+
+ `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation.
+ """