summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py34
1 files changed, 0 insertions, 34 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py
deleted file mode 100644
index 2c12fcf..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/server.py
+++ /dev/null
@@ -1,34 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-from typing import TYPE_CHECKING
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-if TYPE_CHECKING:
- from litestar.openapi.spec.server_variable import ServerVariable
-
-__all__ = ("Server",)
-
-
-@dataclass
-class Server(BaseSchemaObject):
- """An object representing a Server."""
-
- url: str
- """
- **REQUIRED**. A URL to the target host.
-
- This URL supports Server Variables and MAY be relative, to indicate that the host location is relative to the
- location where the OpenAPI document is being served. Variable substitutions will be made when a variable is named in
- ``{brackets}``.
- """
-
- description: str | None = None
- """An optional string describing the host designated by the URL.
-
- `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation.
- """
-
- variables: dict[str, ServerVariable] | None = None
- """A map between a variable name and its value. The value is used for substitution in the server's URL template."""