summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py
deleted file mode 100644
index 5e4e195..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/request_body.py
+++ /dev/null
@@ -1,38 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-from typing import TYPE_CHECKING
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-if TYPE_CHECKING:
- from litestar.openapi.spec.media_type import OpenAPIMediaType
-
-__all__ = ("RequestBody",)
-
-
-@dataclass
-class RequestBody(BaseSchemaObject):
- """Describes a single request body."""
-
- content: dict[str, OpenAPIMediaType]
- """
- **REQUIRED**. The content of the request body.
- The key is a media type or `media type range <https://tools.ietf.org/html/rfc7231#appendix-D>`_ and the value
- describes it.
-
- For requests that match multiple keys, only the most specific key is applicable. e.g. ``text/plain`` overrides
- ``text/*``
- """
-
- description: str | None = None
- """A brief description of the request body. This could contain examples of use.
-
- `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation.
- """
-
- required: bool = False
- """Determines if the request body is required in the request.
-
- Defaults to ``False``.
- """