summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
commit6d7ba58f880be618ade07f8ea080fe8c4bf8a896 (patch)
treeb1c931051ffcebd2bd9d61d98d6233ffa289bbce /venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
parent4f884c9abc32990b4061a1bb6997b4b37e58ea0b (diff)
venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
new file mode 100644
index 0000000..5ee2a95
--- /dev/null
+++ b/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
@@ -0,0 +1,38 @@
+from __future__ import annotations
+
+from dataclasses import dataclass
+
+from litestar.openapi.spec.base import BaseSchemaObject
+
+__all__ = ("Reference",)
+
+
+@dataclass
+class Reference(BaseSchemaObject):
+ """A simple object to allow referencing other components in the OpenAPI document, internally and externally.
+
+ The ``$ref`` string value contains a URI `RFC3986 <https://tools.ietf.org/html/rfc3986>`_ , which identifies the
+ location of the value being referenced.
+
+ See the rules for resolving `Relative References <https://spec.openapis.org/oas/v3.1.0#relativeReferencesURI>`_.
+ """
+
+ ref: str
+ """**REQUIRED**. The reference identifier. This MUST be in the form of a URI."""
+
+ summary: str | None = None
+ """A short summary which by default SHOULD override that of the referenced component.
+
+ If the referenced object-type does not allow a ``summary`` field, then this field has no effect.
+ """
+
+ description: str | None = None
+ """A description which by default SHOULD override that of the referenced component.
+
+ `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation. If the referenced
+ object-type does not allow a ``description`` field, then this field has no effect.
+ """
+
+ @property
+ def value(self) -> str:
+ return self.ref.split("/")[-1]