summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
deleted file mode 100644
index 5ee2a95..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/reference.py
+++ /dev/null
@@ -1,38 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-__all__ = ("Reference",)
-
-
-@dataclass
-class Reference(BaseSchemaObject):
- """A simple object to allow referencing other components in the OpenAPI document, internally and externally.
-
- The ``$ref`` string value contains a URI `RFC3986 <https://tools.ietf.org/html/rfc3986>`_ , which identifies the
- location of the value being referenced.
-
- See the rules for resolving `Relative References <https://spec.openapis.org/oas/v3.1.0#relativeReferencesURI>`_.
- """
-
- ref: str
- """**REQUIRED**. The reference identifier. This MUST be in the form of a URI."""
-
- summary: str | None = None
- """A short summary which by default SHOULD override that of the referenced component.
-
- If the referenced object-type does not allow a ``summary`` field, then this field has no effect.
- """
-
- description: str | None = None
- """A description which by default SHOULD override that of the referenced component.
-
- `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation. If the referenced
- object-type does not allow a ``description`` field, then this field has no effect.
- """
-
- @property
- def value(self) -> str:
- return self.ref.split("/")[-1]