summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
commit6d7ba58f880be618ade07f8ea080fe8c4bf8a896 (patch)
treeb1c931051ffcebd2bd9d61d98d6233ffa289bbce /venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py
parent4f884c9abc32990b4061a1bb6997b4b37e58ea0b (diff)
venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py
new file mode 100644
index 0000000..c322efc
--- /dev/null
+++ b/venv/lib/python3.11/site-packages/litestar/openapi/spec/oauth_flow.py
@@ -0,0 +1,36 @@
+from __future__ import annotations
+
+from dataclasses import dataclass
+
+from litestar.openapi.spec.base import BaseSchemaObject
+
+__all__ = ("OAuthFlow",)
+
+
+@dataclass
+class OAuthFlow(BaseSchemaObject):
+ """Configuration details for a supported OAuth Flow."""
+
+ authorization_url: str | None = None
+ """
+ **REQUIRED** for ``oauth2`` ("implicit", "authorizationCode"). The authorization URL to be used for this flow. This
+ MUST be in the form of a URL. The OAuth2 standard requires the use of TLS.
+ """
+
+ token_url: str | None = None
+ """
+ **REQUIRED** for ``oauth2`` ("password", "clientCredentials", "authorizationCode"). The token URL to be used for
+ this flow. This MUST be in the form of a URL. The OAuth2 standard requires the use of TLS.
+ """
+
+ refresh_url: str | None = None
+ """The URL to be used for obtaining refresh tokens.
+
+ This MUST be in the form of a URL. The OAuth2 standard requires the use of TLS.
+ """
+
+ scopes: dict[str, str] | None = None
+ """
+ **REQUIRED** for ``oauth2``. The available scopes for the OAuth2 security scheme. A map between the scope name and a
+ short description for it the map MAY be empty.
+ """