summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py28
1 files changed, 0 insertions, 28 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py
deleted file mode 100644
index b779bb4..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/license.py
+++ /dev/null
@@ -1,28 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-__all__ = ("License",)
-
-
-@dataclass
-class License(BaseSchemaObject):
- """License information for the exposed API."""
-
- name: str
- """**REQUIRED**. The license name used for the API."""
-
- identifier: str | None = None
- """An
- `SPDX <https://spdx.github.io/spdx-spec/v2.3/SPDX-license-list/#a1-licenses-with-short-identifiers>`_ license expression for the API.
-
- The ``identifier`` field is mutually exclusive of the ``url`` field.
- """
-
- url: str | None = None
- """A URL to the license used for the API.
-
- This MUST be in the form of a URL. The ``url`` field is mutually exclusive of the ``identifier`` field.
- """