summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py50
1 files changed, 0 insertions, 50 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py
deleted file mode 100644
index 1d858db..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/info.py
+++ /dev/null
@@ -1,50 +0,0 @@
-from __future__ import annotations
-
-from dataclasses import dataclass
-from typing import TYPE_CHECKING
-
-from litestar.openapi.spec.base import BaseSchemaObject
-
-if TYPE_CHECKING:
- from litestar.openapi.spec.contact import Contact
- from litestar.openapi.spec.license import License
-
-__all__ = ("Info",)
-
-
-@dataclass
-class Info(BaseSchemaObject):
- """The object provides metadata about the API.
-
- The metadata MAY be used by the clients if needed, and MAY be presented in editing or documentation generation tools
- for convenience.
- """
-
- title: str
- """
- **REQUIRED**. The title of the API.
- """
-
- version: str
- """
- **REQUIRED**. The version of the OpenAPI document which is distinct from the
- `OpenAPI Specification version <https://spec.openapis.org/oas/v3.1.0#oasVersion>`_ or the API implementation version
- """
-
- summary: str | None = None
- """A short summary of the API."""
-
- description: str | None = None
- """A description of the API.
-
- `CommonMark syntax <https://spec.commonmark.org/>`_ MAY be used for rich text representation.
- """
-
- terms_of_service: str | None = None
- """A URL to the Terms of Service for the API. MUST be in the form of a URL."""
-
- contact: Contact | None = None
- """The contact information for the exposed API."""
-
- license: License | None = None
- """The license information for the exposed API."""