summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:10:44 -0400
commit6d7ba58f880be618ade07f8ea080fe8c4bf8a896 (patch)
treeb1c931051ffcebd2bd9d61d98d6233ffa289bbce /venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
parent4f884c9abc32990b4061a1bb6997b4b37e58ea0b (diff)
venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
new file mode 100644
index 0000000..b816288
--- /dev/null
+++ b/venv/lib/python3.11/site-packages/litestar/openapi/spec/contact.py
@@ -0,0 +1,21 @@
+from __future__ import annotations
+
+from dataclasses import dataclass
+
+from litestar.openapi.spec.base import BaseSchemaObject
+
+__all__ = ("Contact",)
+
+
+@dataclass
+class Contact(BaseSchemaObject):
+ """Contact information for the exposed API."""
+
+ name: str | None = None
+ """The identifying name of the contact person/organization."""
+
+ url: str | None = None
+ """The URL pointing to the contact information. MUST be in the form of a URL."""
+
+ email: str | None = None
+ """The email address of the contact person/organization. MUST be in the form of an email address."""