summaryrefslogtreecommitdiff
path: root/venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py
diff options
context:
space:
mode:
authorcyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
committercyfraeviolae <cyfraeviolae>2024-04-03 03:17:55 -0400
commit12cf076118570eebbff08c6b3090e0d4798447a1 (patch)
tree3ba25e17e3c3a5e82316558ba3864b955919ff72 /venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py
parentc45662ff3923b34614ddcc8feb9195541166dcc5 (diff)
no venv
Diffstat (limited to 'venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py')
-rw-r--r--venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py24
1 files changed, 0 insertions, 24 deletions
diff --git a/venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py b/venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py
deleted file mode 100644
index c4bb129..0000000
--- a/venv/lib/python3.11/site-packages/litestar/openapi/spec/callback.py
+++ /dev/null
@@ -1,24 +0,0 @@
-from __future__ import annotations
-
-from typing import TYPE_CHECKING, Dict, Union
-
-if TYPE_CHECKING:
- from litestar.openapi.spec.path_item import PathItem
- from litestar.openapi.spec.reference import Reference
-
-
-Callback = Dict[str, Union["PathItem", "Reference"]]
-"""A map of possible out-of band callbacks related to the parent operation. Each value in the map is a
-`Path Item Object <https://spec.openapis.org/oas/v3.1.0#pathItemObject>`_ that describes a set of requests that may be
-initiated by the API provider and the expected responses. The key value used to identify the path item object is an
-expression, evaluated at runtime, that identifies a URL to use for the callback operation.
-
-Patterned Fields
-
-{expression}: 'PathItem' = ...
-
-A Path Item Object used to define a callback request and expected responses.
-
-A `complete example <https://github.com/OAI/OpenAPI-Specification/blob/main/examples/v3.1/webhook-example.yaml>`_ is
-available.
-"""